Foundations Team Updates - Thursday 10 Aug 2023

Previous week’s status can be found at Foundations Team Updates - Thursday 03 Aug 2023

1 Like

Armhf time_t conversion to 64bit

  • Evaluate packages

Ubuntu 22.04.3 release

  • Test RISC-V images

Silicon vendor collaboration

  • Review upcoming U-Boot patches


  • Review written interviews
  • Completed mdadm merge from Debian unstable, final testing before uploading
  • Proposed migration:
    • livecd-rootfs blocking lsb-release-minimal, livecd-rootfs seems a bit flaky; passed after some retries
  • Candidate interviews
  • Reviewed and sponsored dnspython for @pushkarnk
  • +1 Maintenance shift


  • rdma-core: Release new upstream version 47.0-1 to unstable
  • tzdata: Release 2023c-8 to unstable and 2023c-8ubuntu1 to mantic to move all legacy timezone symlinks to tzdata-legacy. I overshot (e.g. moved UTC to tzdata-legacy) and had to release 2023c-9/2023c-10 and 2023c-9ubuntu1 to fix it.
  • dhcpcd: Sponsored upload of 10.0.2-3ubuntu1 for Tobias Heider (to build against OpenSSL)
  • python-tz: Release 2023.3-4 to unstable to not needing to depend on tzdata-legacy
  • python-dateutil: Release 2.8.2-3 to unstable to depend on tzdata-legacy in autopkgtest

armhf time_t

Summary for armhf time_t full shift for the week 31:

  • 2023-08-01: 9 packages
  • 2023-08-02: 21 packages
  • 2023-08-03: 20 packages
  • 2023-08-04: 31 packages

Processing packages in batches helped speeding up. I reserved around 50 packages on, ran the check over all of them (preferrable over night), then looked at the failures, committed fixes for them. Then ran the check over all “fixed” packages and afterwards check the logs again to see if they succeeded or if more fixes were needed.

I started a discussion on the debian-devel mailing list about adding autodep8 test for C/C++ header. This would highlight issues earlier and help the next time we have to analyze C/C++ headers.

proposed migration

The cryptsetup autopkgtest was failing and blocking linux-meta to migrate. The failure:

qemu-system-x86_64: ../../util/cacheflush.c:212: init_cache_info: Assertion `(isize & (isize - 1)) == 0' failed.

This is qemu bug #2016252. Retrying the autopkgtest worked.






  • Take-home test reviews


  • 1.71 review+upload
  • MIR vendoring discussions
  • a bit of s390-tools work (they started shipping some Rust code!)


  • 2.38 upload (twice!)
  • Investigation of autopkgtest failures in the Jammy SRU


  • Backporting of AVX512 patches from Intel, right on time for Downfall to hit and delay their landing while we sort that out.


  • Take-home tests




  • Still discussing Rust plugin issue with the Snapcraft Team regarding LP#1990950


  • working on recovery key support for LUKS+LVM use-case (no MP yet)
  • played around with canary image
  • encountered an apparmor issue when using swtpm with virt-manager on lunar. Uploaded a fixed version for mantic (thanks @tsimonq2 for sponsoring!). Might be worth SRUing?
  • addressed crash in subiquity’s manual partitioning for the 22.04.3 release:
  • ISO testing on two different XPS 13 hardware models



  • Interviewer training


  • Submitted MR 448714 that fixed a bunch of issues in the launcher, corrected dangling symlinks in the installation and also updated the autopkgtests tests to use the launcher
  • Code review for 448754



  • Researching the OpenJDK/Java + FIPS ecosystem
  • DebConf 23 formalities
1 Like


  • Investigated and reported a problem on lcov that affects netplan development. The last upload is missing a file. LP#2029924
  • Prepared a sudo merge LP#2030914
  • Investigating why Vim build is failing on ppc64el. Apparently some encryption-related tests are failing because the system doesn’t have enough memory. libsodium calls to mlock(2) seems to be failing. In my ppc64el instance the build gets stuck and doesn’t even get to the tests…


  • Published the first netplan diff PR for review PR#386
  • Created a project on for Netplan and configured some automation to run it once a week PR#391
  • Addressed some issues found during code review on my veth PR. It’s just pending an agreement on the new interface name in Netplan (which will probably be virtual-ethernets) PR#368
  • Netplan status --verbose (only used to show route from all the tables at the moment) merged PR#390


  • Go 1.21 is released. Updated the Debian package and snap.
  • Change golang-defaults to 1.21 in Debian experimental. The pseudo migration excuse looks good.
  • Continue fixing packages that FTBFS with golang-1.21.
    Mostly working on golang-gvisor-gvisor and golang-github-lucas-clemente-quic-go, which should fix the remaining packages, as they are the root cause for the other packages’ FTBFS. But updating them need to fix another round of incompatibility for the new versions.
  • Short week; covering school holidays
  • Couple of days of ISO testing for jammy’s .3 release
  • Finished editing and publishing all the desktop flavours posts
  • Pi meetings
  • Bumped build-hat to current version
  • Working on updated firmware and rpiboot packages


  • Worked with @andersson123 to debug an issue where test requests were returning an “invalid request” error message.
  • Worked around an issue with the latest version of the rabbitmq-server charm by specifying an older version of the charm.
  • Submitted an MP for the mojo service-bundle which specifies the version of the rabbitmq-server charm to use.

ISO Tracker

  • Resolved an issue with download URLs for Ubuntu Desktop and Jammy for the 22.04.3 point release.


  • Performed SRU verification of an SRU which I had sponsored.
  • Reported bug 2028888 regarding Firefox not being installed in the daily-canary live environment.
  • Reported bug 2028889 regarding a small root disk forcing you to choose the hardware-backed FDE install option with the daily-canary.
  • Reported bug 2028984 regarding the .manifest file for the daily-canary image not having snaps listed.
  • Modified package-subscribers, part of ubuntu-archive-tools, so that the set of ESM releases is up to date.
  • Submitted an MP switching packages-subscribers to use anonymous access to Launchpad instead of logging in.
  • Worked on the migration of reports which are viewable at to a different server.


  • Short week due to holidays last week.
  • Attended Developer Membership Board meeting.
  • Reviewing candidate applications.

Short week due to sick day on Monday.


  • Working on nvme-stas MIR:
    • Creating an nvme-of test case for the package as recommended by the MIR team (in progress).


  • Working on packaging dotnet8 preview7 release with new versioning scheme from the specification.
  • Attended the weekly .NET Partners Sync meeting


  • Making amendments and fixes and deploying a change which restricts duplicate requests from being queued
  • Making fixes to a change which implements a custom HTTP exit code suite to better inform users of errors when using autopkgtest-cloud
  • Working on a service which reports these HTTP error codes to grafana (will hopefully help us discover problems quicker)
  • Working on the graphs in Grafana to visualise this data
  • Working on an MP which adds a pre-commit hook to LPCI which places a text file in the charm directories with git information, so that when deploying the charm somewhere you can see the git information running up to when the charm was packed. Hopefully will make it easier to connect charm revisions and the git history.


  • Testing some errors we were having, still in progress


1 Like


nfs-utils: merged 1:2.6.3-2 from debian


  • validated armhf failures for ManyRequestsLegacy and RandomTestBsi1999. Tests remain disabled as those are CI-specific failures. Could not reproduce with real hardware.
  • submitted small mp to update patches for openjdk-11 (ea builds)
  • openjdk 22 build failure on S390x and armhf is being worked on upstream


  • openjdk-11 and -17 early access fail to build due to mismatch in jtreg version string. The work in progress merge proposal switches to using Makefile instead of ant build. This solves this particular issue and also we stop using unsupported jtreg build system.
1 Like