Foundations Team Updates - Thursday 07 July 2022

Last week’s update is available at

1 Like

+1 maintenance

  • golang-mongodb-mongo-driver - Fixed FTBFS in Ubuntu (and forwarded to Debian) which unblocked:
    • golang-github-go-openapi-strfmt
    • golang-github-go-openapi-validate
    • golang-github-go-openapi-runtime
  • golang-github-openshift-imagebuilder: Fixed FTBFS in Ubuntu and forwarded to Debian
  • scamper - Fixed FTBFS in Ubuntu and forwarded to Debian
  • golang-oras-oras-go - Fixed FTBFS in Ubuntu and forwarded to Debian
  • Chasing down circular dependency between golang-github-jackc-pgtype and golang-github-jackc-pgx. Thanks @vorlon for Archive Admin support


  • Merged germinate PR
  • Created createChroot PR
  • Worked on configuring PPAs in the newly created chroot and installing packages to it.


  • Chasing down curl FTBFS. Ran into the “failed builds with no logs” issue.
1 Like
  • subiquity
    • PR: 1341 - work for Guided Install to work by resizing then performing guided in the space remaining. This adds the capability for ubuntu-desktop-installer to perform guided installs by resizing an existing partition, or using already existant free space.
    • Review PR: 1331, 1340, 1342
    • Spec reviews
  • curtin
    • (no MP yet) - fix preserved partitions on GPT tables - retain values for uuid, attrs, name if unspecified, and add ability to specify name and attrs (uuid is already there). Retain the disk value first-lba, even if it looks a bit odd.

4 day week

1 Like

Short week due to US holiday.

Did an SRU team shift on Friday. Substantially reduced the size of the jammy queue. Also left a number of packages in the queue with questions on them; in particular a number of GNOME uploads by the Desktop Team that appear to be intended to be included under the GNOME SRU exception but that cannot be clearly traced to an approved acception.

+1 Maintenance
On +1 maintenance rotation this week. The following will all be posted to ubuntu-devel at the end of my rotation as well.

I focused on working through the packages on the update_excuses page in reverse-age order, and either fixing or ensuring that there is a linked update-excuse bug.

  • gitlab-ci-multi-runner: clarified the language in the linked update-excuse bug. Filed about the undeclared build-deps, since it’s a bug in Debian as well. Further, the package fails to build in Debian for unrelated reasons even if we fix the incompatibility with Ubuntu’s docker stack (which I was not able to immediately figure out, Debian and Ubuntu currently have golang-github-docker-docker-dev from the same upstream branch) so I’ve removed the package from -proposed.
  • gcc-defaults-mipsen: not migrating because gcc-11-cross-mipsen isn’t building, but things are in better shape than they were last time I looked at this in the jammy cycle. But cross-toolchain-base-mipsen seems to be built differently in Debian than Ubuntu, resulting in file conflicts. I’ve opened LP: #1980779 for tracking this.
  • racket-mode: autopkgtests failing on armhf and arm64. They are also failing on armhf in Debian testing so I would consider having us ignore this failure, but the arm64 autopkgtest failure is seen only in Ubuntu. However, I also noticed that the release version of racket-mode had autopkgtest results where no tests were run. If I ran the tests from the -proposed source package against the release version of the binary packages, the tests also failed. Hinted this package through since these test failures are not
    a regression.
  • gitbrute: failing to build on ppc64el with a weird error about the resulting go binary’s build ID having the wrong length. Closer inspection shows that the package is build-depending on gccgo-go instead of the default golang-go for no reason that can be discerned from the changelog. Switching the package to build using golang-go fixes the build failure. Uploaded, and
    forwarded to Debian at
  • libbpp-phyl: regresses bppsuite autopkgtests on arm64 and s390x. This is a Debian-only update with no upstream changes, so seems to a problem of a misbuilt library on these archs. Rebuilding libbpp-phyl on s390x with current gcc still shows the failure. The last working build was done two years ago; rebuilding with gcc-9 also still shows the failure. So I tried building with DEB_BUILD_OPTIONS=optimize=-lto and this fixed the test failures, so uploaded.
  • sphde: the first thing I noticed with this package is that the Debian changes all relate to fixing a build failure with newer compilers, but that the ftbfs report didn’t flag that this is a package whose buildability had regressed. Had a chat with Graham about this, neither of us is clear on why it’s not showing as a regression; I think this is a bug in the ftbfs report though. So then I tried to reproduce this in an arm64 VM (with an armhf container) and saw very confusing behavior because the testsuite doesn’t clean up the directory after itself. Eventually succeeded in establishing some reproducibility, and uploaded the package with the necessary set of patches disabled to get this building everywhere. Filed upstream.
  • mbdyn: FTBFS in Debian and Ubuntu, not in Debian testing; removed the broken
    package from -proposed.
  • materialize: buggy also in Debian, build-depends on a non-existent package ( Added to extra-removals in the sync-blacklist; possibly the first time this has been done with a binary package but it should work.
  • aspectc++: RC-buggy in Debian, not in testing and not in the release pocket, so removed from -proposed leaving it to Debian to fix.
  • libtickit-widget-scrollbox-perl: blocked by a block-proposed bug from
    February (LP: #1962411) about autopkgtests having regressed, which is a condition we can’t handle directly in proposed-migration. Re-triggered tests to see if they work any better now than before, since they are now passing in Debian; they passed, so the bug is now closed to let the package migrate.
  • radare2: build-depends on freebsd-glue, which is RC-buggy in Debian. This was blacklisted in Ubuntu as a ‘kfreebsd’ package but I don’t think that’s correct, as the package exists to provide a userspace glue layer on Linux. I’ve un-blacklisted it, but also removed radare2 and added it to extra-removals since it won’t be buildable until/unless someone fixes freebsd-glue for the current gcc.
  • roundcube: was fixed in Debian, but only in experimental. Manually synced the experimental version; it’s a release-candidate version but that’s better than the existing version in kinetic failing to build or run with the currently-shipped php (LP: #1950326).

Build openvswitch-switch-dpdk for riscv64

  • build in ppa for riscv64


  • cannot be booted with KVM and smp on riscv64 (LP #1980594)
    Provide reproducible example to upstream maintainer

Test environment for network applications (DPDK, SPDK, OpenVSwitch, rdma-core)*

  • Continue implementation
1 Like


  • Merged PR 1331 to match design mockups for Ubuntu Pro with manual token input.
  • Have a working implementation of magic-attach in Subiquity. Tested successfully against the staging environment. Unfortunately, this needs to be updated again following a design change. Need new mockups to move on. I will split up the diff and open PR(s) for the bits that can already land.
  • Opened and merged PR 1342 - made distinction between invalid tokens and other more generic errors when invoking ubuntu-advantage.
  • Attended different meetings for Ubuntu Pro with magic-attach.
  • Attended cloud-config meeting to make Subiquity / cloud-config interaction more user friendly.
  • Started to look in details at the interaction between Subiquity and Curtin - so that we can go with a more incremental approach when invoking Curtin.
1 Like




  • organizational stuff with HR
  • Candidate interview
1 Like


  • Fixed up the specification for deb822 by default and published it
  • APT calls for testing
  • Analysis into failure to install libudev-dev on a clean jammy container; it removes systemd instead of upgrading udev, developed 3 fixes, hoping to get feedback on them from DonKult upstream
  • Got notified in Debian about APT breaking because of MD5 use Description-md5 (and I guess downloads); when libgcrypt is running in FIPS mode. Did some early investigation, but was unable to reproduce unexpectedly.
  • Asked DonKult for topics I should bring up from his side in the talk



  • Read a weird proposal
1 Like

Short week:

  • livecd-rootfs: Fix review from @sil2100, master branch merged, jammy under review
  • flash-kernel: Does not run in a container, which we need for RISC-V images, currently testing a fix
  • Preparing bluetooth firmware package for the VisionFive that we’ll push into RISC-V PPA
  • Start thinking about RISC-V extensions and how we will handle that
  • usb-creator MIR: Forwarded symbol patches to Debian, under discussion there (at least I had an answer, I have to respond :))
1 Like
  • FTBFS reports: kinetic baseline and kinetic GCC12
    (mass retry completed on amd64, i386, ppc64el and s390x, test rebuild still running on arm64, armhf and riscv64)
  • Investigating which packages keep configuration files in /etc/
  • Proposed migration:
    • python3-stdlib-extensions vs python-bayespy: retried autopkgtests against the new python-bayespy which had just migrated
    • llvm-toolchain-14 vs fenics-dolfinx: triggered the autopkgtests of xsimd and pythran together, so they and fenics-dolfinx could migrate, then retried the fenics-dolfinx autopkgtests
  • Sync’d pymupdf (TIL universe package)
  • DebConf22 preparations
1 Like

Short week with US holiday.



1 Like

The Ubuntu QA Team’s status can be found here:

1 Like


I spent most of my time working on Apports autopkgtest. I fixed several autopkgtest failures on non-x86 architectures and uploaded apport 2.22.0-0ubuntu3 to kinetic. Changes:

  • Fixed test_core_dump_packaged test flaky on arm64 and ppc64el (LP: #1980390)
  • tests: Fix test_add_gdb_info_script on armhf
  • tests: Fix wrong Ubuntu archive URI on ports
  • tests: Fix KeyError in test_install_packages_unversioned
  • Fix trying to find debug packages for non-existing version
  • tests: Upgrade APT tests to use Ubuntu 22.04 (jammy) (for autopkgtest)
  • tests: Fix IndexError in test_crash_setuid_drop
  • tests: Print Apport log if no report is found

The autopkgtest for s390x has one failure (will be fixed by using sleep as test executable). Also one armhf test case fail which is related to running in a lxd container. I am currently investigating/debugging.


1 Like
  • raspi-config:
    • more integration work (LP: #1972982)
    • disabled VNC functions (no equivalent)
    • fixed the power LED / activity option
    • fixed screen blanking option
    • disabled the xcompmgr option (no equivalent)
    • fixed the wayland/X11 switch
    • fixed wlan country selection
    • still working on other networking bits before pushing it…
  • Added entry for RISC-V QEMU to flash-kernel (LP: #1980519)
  • Firefox performance measurement and work
    • investigated MATE differences (as of 22.04 no significant differences in ff)
    • still looking into multi-CPU squashfs investigation
  • Pi meetings
1 Like