Can Fuse come pre-installed on 22.10?

I am really liking the Ubuntu 22.10 so far, with the exception of this bug. Anyway, can the package fuse come preinstalled on Ubuntu 22.10? AppImages do not launch without it. I tried to run the JetBrains ToolBox app, but it wouldn’t launch until I ran sudo apt install fuse. Adding this package as default would make people’s lives a bit easier. :slight_smile: Is there still time to make a change like this?

The need to install libfuse2 is mentioned in both the Ubuntu 22.04 LTS release notes and the AppImage documentation.

Ubuntu has switched to fuse3 in the main section. To install libfuse2 by default anyway would be unusual and we’d need the Ubuntu Security Team to agree that they would want to maintain security support for an unmaintained obsolete library.

Ubuntu supports apt and Snap by default. It’s a single package to install if you want to use AppImage, and another package if someone wants to use Flatpak.

6 Likes

For those googling into this issue, some better context can be found in https://github.com/AppImage/AppImageKit/issues/1219 , which directs to https://docs.appimage.org/user-guide/troubleshooting/fuse.html#setting-up-fuse-2-x-alongside-of-fuse-3-x-on-recent-ubuntu-22-04-debian-and-their-derivatives

One thing to note about AppImage support and possible user frustration to @jbicha , Ubuntu’s own install documentation ( https://ubuntu.com/tutorials/install-ubuntu-desktop#3-create-a-bootable-usb-stick ) references Balena Etcher ( https://www.balena.io/etcher/ ), whose default downloadable on Linux is a zipped AppImage file.