Call for testing: chromium-browser deb to snap transition

It’s not using basic password store. Not keyring. I used to edit edit Exec parameter like --password-store=basic in chromium-browser.desktop file

Thanks. That worked. But in next reboot it again doesn’t. I used to edit edit Exec parameter like --password-store=basic in chromium-browser.desktop file (in ~/.local/share). Can’t we do something similar in which settings will be persisted even after upgrade ?

The connected state of the password-manager-service interface is persistent across reboots, so unless you connect it manually, if it was disconnected it will remain so.

Note that if you’re on 19.10 and recently updated chromium-browser, the preinst script might have forcefully connected the interface for you (see bug #1836616). This is a one-off action, so it should be safe to manually disconnect the interface again, and hopefully this won’t happen again.

And this is now fixed. I uploaded an updated deb to eoan, it will be available soon to all eoan users.

2 Likes

Broken again , cant load it:

chromium_chromium.desktop[1698]: cannot create cgroup hierarchy /sys/fs/cgroup/devices/snap.chromium.chromium/: No such file or directory

Can you report that on https://forum.snapcraft.io/ with details about the Ubuntu version you are using and ‘snap version’ output?

Hi,

Since the last 19.10 updates, Chromium icon disappeared from Dock, but its place is still empty and when I hover with the mouse, the text “Navigateur Web Chromium” is well shown on the bubble.

If i run in terminal: chromium-browser

Le schéma « com.canonical.Unity.Launcher » n’existe pas (doesn’t exist)
erreur interne, veuillez le signaler : l’exécution de “chromium” a échoué : cannot find installed snap “chromium” at revision 817: missing file /snap/chromium/817/meta/snap.yaml

And snap list:

Nom                   Version                     Révision  Suivi     Éditeur     Notes
chromium                                          817       stable    canonical✓  cassé
core                                              7270      stable    canonical✓  cassé
core18                20190723                    1074      stable    canonical✓  base
...

This indicates that, for some reason, the core and chromium snaps are broken.

Can you share the output of snap changes core and snap changes chromium ?

After the next startup, all is back to normal - in the meantime I did no updates nor modification. When I had the error, it was also after a computer startup (last updates were done before)…

snap list
Nom                   Version                     Révision  Suivi     Éditeur     Notes
chromium              76.0.3809.87                817       stable    canonical✓  -
core                  16-2.39.3                   7270      stable    canonical✓  core
core18                20190723                    1074      stable    canonical✓  base
gnome-3-26-1604       3.26.0.20190705             90        stable/…  canonical✓  -
gnome-3-28-1804       3.28.0-10-gaa70833.aa70833  67        stable    canonical✓  -
gnome-calculator      3.32.1                      406       stable/…  canonical✓  -
gnome-characters      v3.32.1+git2.3367201        296       stable/…  canonical✓  -
gnome-logs            3.32.0-4-ge8f3f37ca8        61        stable/…  canonical✓  -
gnome-system-monitor  3.32.1-3-g0ea89b4922        100       stable/…  canonical✓  -
gtk-common-themes     0.1-22-gab0a26b             1313      stable/…  canonical✓  -

snap changes chromium
erreur : aucun changement trouvé

snap changes core
erreur : aucun changement trouvé

Glad that this is fixed, although it’s slightly worrying that the breakage happened in the first place…

General observation that is more a ‘feeling’.

I find chromium re-opens without restoring my tabs a lot more often than it used to since it switched to snap. Right now it refuses to restore so I’m re-creating my default tabs again…

To test a lubuntu-grub-theme I just closed chromium on my 19.10 box (~10 mins back), then logged out/rebooted; after reboot (viewing grub as displayed) I log back in and my chromium wouldn’t restore my settings…

I suspect I need to wait far longer than I do (which was no time) between closing chromium and the logout/reboot steps; I don’t know if this is true or not, but it seems to occur only on fast reboots (such as reboot just to test something minutes ago) thus I wonder if snap is slowed to shutdown cleanly compared to long ago when chromium wasn’t snap).

I can’t prove any of this, but snap list shows (edited)
chromium 76.0.3809.87 817 stable canonical✓ -
core 16-2.39.3 7270 stable canonical✓ core
I was logged in with XFCE & rebooted to XFCE

1 Like

I have used Ubuntu on a daily base since version 9.10. Until now I have uninstalled snapd with each new version it came with (and installed the deb-based calculator). I have just installed 19.10 and noticed the change. I will definitely stop using Ubuntu now. I hate the whole concept of snap and imposing it on users is IMHO an incredibly bad (to keep it civil) idea. Chromium is the application I use most so this is a big nono for me.

I am now deciding on which distro to switch to. Manjaro looks promising but I have not yet decided. Suggestions or pointers by any other switchers are more than welcome.

1 Like

Debian or Mint would be the closest Distros to Ubuntu (dpkg/apt).

Other than switching, there might be unofficial PPAs when Chromium becomes the default. The debs from Debian could work as well. I am a Firefox aficionado, so I don’t really know for Google, but at least Mozilla hosts official upstream builds.

@sbierman I have to agree. I’ve stopped using LXD since it became a snap-only option and now I can’t use Chromium because of errors so even though I am totally invested in Ubuntu as a server system I think I am going to adopt some other KDE/Plasma based distro. Snaps might be acceptable if they actually worked and did not add an extra 3% CPU overhead (on my i9 cpu) but I seem to have an endless stream of issues with snap based software. For instance with chromium-browser I have reinstalled it several times including completely removing the snapd package and I still get this error…

~ chromium-browser
No such schema “org.gnome.shell”
No such schema “com.canonical.Unity.Launcher”
cannot create cgroup hierarchy /sys/fs/cgroup/devices/snap.chromium.chromium/: No such file or directory

and the only link google provides for the last line is this thread. In all other respects I am totally happy with Kubuntu and have been a contented user for two decades but I am losing the capability of key important apps (LXD now chromium) that I depend on, or used to, LXD is a lost cause for the last year.

1 Like

@guiverc: that sounds like an update of the chromium snap is being installed just after boot, and you launch it while snapd hasn’t finished copying over the profile directory.
To test out this hypothesis, can you wait a couple of minutes before launching chromium after logging in to your session and report back here after a few times doing this, over say a period of two weeks?

Also, how big is your chromium profile directory?

 du -sh ~/snap/chromium/current/.config/chromium
1 Like

Have you tried reporting this error on the snapcraft forum?

Similarly, have you reported this extra 3% CPU overhead and your endless stream of issues, there or in bug reports?

Please don’t assume that all issues are known and won’t be fixed. The first step towards fixing an issue is reporting it.

3 Likes

@oSoMoN : Yes your description does fit I believe. First thing in the mornings I’m more interested in drink/food & am thus more patient, but during the day… or in that case I wanted to return to phab.lub… to report … nah I’d have had no patience… I will try and sit on my hands… (& report back) :slight_smile:

guiverc@d960-ubu2:~$ du -sh ~/snap/chromium/current/.config/chromium
178M /home/guiverc/snap/chromium/current/.config/chromium

I just re-opened chromium and had it lose my prior session/tabs… (it said it’d crashed and offered to re-open top right, but opened sessions from long ago with many windows where I’d closed all but a single window (many tabs) awhile before I closed chromium.

Possible cause this time maybe because I’d kept the chromium.snap opened whilst I was completing a task which I did over ~60 hours (task didn’t take that long, it was mostly sitting idle, me doing other things or machine suspended) so an updated snap was waiting on me to close it??? I’d closed chromium with intention of heading to bed, but was pinged on irc so quickly re-opened chromium this time (no logout/login was involved)

This sounds like the same symptoms of not having refresh app awareness. The snap updated while you were using it, and all of the tabs and windows you had open in that one process saved their data to the old revision data folder rather than the new one, so when you re-opened, you opened the new revision that never got the new data.

You could try doing snap revert and see if you can now re-open the tabs and windows you had closed. If so, then yes this is another manifestation of the refresh app awareness problem.

Unfortunately I don’t know enough about chromium and it’s data to say for sure whether or not you could just copy the old revision data to the new revision data folder and have the new one work.

2 Likes

I closed chromium, tried snap revert, then re-opened chromium

guiverc@d960-ubu2:~$ snap revert chromium
chromium reverted to 76.0.3809.87

It reopened tons of windows as if I was back on working on lubu-qa-testcases (the ~60 hour task that I very slowly did (mostly-avoided) that had me leave browser open). I can’t say it was the identical windows as I referred to in my last (10hr ago) post, but it sure felt like it.

Most tabs required me to re-login (half thru ubuntu-one, others like mewe through their own), the gmail didn’t - with it showing an email from Walter (wxl) dated Fri, Aug 16, 2019 at 5:19 AM; an email I believe I dealt with yesterday morning (but by mid yesterday anyway).

1 Like