Autoinstall from cobbler

Hello,
I’m trying to use my cobbler environment to install ubuntu. I have been able to do this before with versions 18 and 20. But it just starts the normal installer every time I boot using ubuntu.

Cobbler is currently running on RHEL 9. And the hypervisor is proxmox.

Here is the command I used to setup the profile in cobbler:

sudo cobbler profile edit --kernel-options='ip=dhcp iso-url=http://10.150.10.17/iso/ubuntu-22.04.4-live-server-amd64.iso url=http://10.150.10.17/iso/ubuntu-22.04.4-live-server-amd64.iso autoinstall cloud-config-url=/dev/null root=/dev/ram0 ramdisk_size=8388608 ds=nocloud-net;s=http://10.150.10.17/cblr/svc/op/autoinstall/profile/Ubuntu-22.04.4-casper-x86_64 boot=casper --autoinstall=http://10.150.10.17/cblr/svc/op/autoinstall/profile/Ubuntu-22.04.4-casper-x86_64 --boot-files=http://10.150.10.17/cblr/distro_mirror/Ubuntu-22.04.4-casper-x86_64/casper/initrd file=http://10.150.10.17/cblr/svc/op/autoinstall/profile/Ubuntu-22.04.4-casper-x86_64 noquiet -- ipv6.disable=true' --name Ubuntu-22.04.4-casper-x86_64 --distro Ubuntu-22.04.4-casper-x86_64 --enable-menu=true

Here is my autoinstall config:

#cloud-config
# See the autoinstall documentation at:
# https://canonical-subiquity.readthedocs-hosted.com/en/latest/reference/autoinstall-reference.html
autoinstall:
  apt:
    disable_components: []
    fallback: offline-install
    geoip: true
    preserve_sources_list: false
    mirror_selection:
      primary:
      - country-mirror:
      - arches: &id001
        - i386
        - amd64
        uri: http://archive.ubuntu.com/ubuntu/
      - arches: &id002
        - s390x
        - arm64
        - armhf
        - powerpc
        - ppc64el
        - riscv64
        uri:  https://ports.ubuntu.com/ubuntu-ports
    security:
      - arches: *id001
        uri: http://security.ubuntu.com/ubuntu
      - arches: *id002
        uri: http://ports.ubuntu.com/ubuntu-ports
  package_update: true
  package_upgrade: true
  codecs:
    install: true
  drivers:
    install: true
  kernel:
    package: linux-generic-hwe-24.04
  power_state:
  mode: reboot
  identity: 
    hostname: ubuntu01
    password: 
    realname: Ubuntu Ubuntu
    username: ubuntu
  keyboard: 
    layout: us
    toggle: null
    variant: ''
  locale: en_US.UTF-8
  network:
    ethernets:
      ens18:
        dhcp4: true
    version: 2
  oem:
    install: auto
  source:
    id: ubuntu-server-minimal
    search_drivers: true
  ssh:
    allow-pw: true
    authorized-keys: []
    install-server: true
#  users: # cloud-config data goes under this heading
  timezone: America/Chicago
  locale: en_US.UTF-8
  prefer_fqdn_over_hostname: false
  fqdn: ubuntu01
  groups:
      - name: 
        gid: 
  users:
    - default
    - name: root
      lock-passwd: false
      passwd: 
      primary_group: root
      ssh_pwauth: yes
    - name: ameyer
      gecos: 
      primary_group: 
      groups: sudo,
      lock-passwd: false
      passwd: 
      shell: /bin/bash
      ssh_pwauth: true
  storage:
    config:
    - {ptable: gpt, path: /dev/sda, wipe: superblock-recursive, preserve: false, name: '',
      grub_device: true, type: disk, id: disk-sda}
    - {device: disk-sda, size: 1048576, flag: bios_grub, number: 1, preserve: false,
      grub_device: false, type: partition, id: partition-0}
    - {device: disk-sda, size: 2147483648, wipe: superblock, flag: '', number: 2,
      preserve: false, grub_device: false, type: partition, id: partition-1}
    - {fstype: ext4, volume: partition-1, preserve: false, type: format, id: format-0}
    - {device: disk-sda, size: 51536461824, wipe: superblock, flag: '', number: 3,
      preserve: false, grub_device: false, type: partition, id: partition-2}
    - name: vg_root
      devices: [partition-2]
      preserve: false
      type: lvm_volgroup
      id: lvm_volgroup-0
    - {name: lv_root, volgroup: lvm_volgroup-0, size: 3221225472B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-0}
    - {fstype: ext4, volume: lvm_partition-0, preserve: false, type: format, id: format-1}
    - {path: /, device: format-1, type: mount, id: mount-1}
    - {name: lv_usr, volgroup: lvm_volgroup-0, size: 8589934592B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-1}
    - {fstype: ext4, volume: lvm_partition-1, preserve: false, type: format, id: format-2}
    - {path: /usr, device: format-2, type: mount, id: mount-2}
    - {name: lv_var, volgroup: lvm_volgroup-0, size: 8589934592B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-2}
    - {fstype: ext4, volume: lvm_partition-2, preserve: false, type: format, id: format-3}
    - {path: /var, device: format-3, type: mount, id: mount-3}
    - {name: lv_var_log, volgroup: lvm_volgroup-0, size: 4294967296B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-3}
    - {fstype: ext4, volume: lvm_partition-3, preserve: false, type: format, id: format-4}
    - {path: /var/log, device: format-4, type: mount, id: mount-4}
    - {name: lv_var_log_audit, volgroup: lvm_volgroup-0, size: 2147483648B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-4}
    - {fstype: ext4, volume: lvm_partition-4, preserve: false, type: format, id: format-5}
    - {path: /var/log/audit, device: format-5, type: mount, id: mount-5}
    - {name: lv_home, volgroup: lvm_volgroup-0, size: 10737418240B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-5}
    - {fstype: ext4, volume: lvm_partition-5, preserve: false, type: format, id: format-6}
    - {path: /home, device: format-6, type: mount, id: mount-6}
    - {name: lv_tmp, volgroup: lvm_volgroup-0, size: 5368709120B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-6}
    - {fstype: ext4, volume: lvm_partition-6, preserve: false, type: format, id: format-7}
    - {path: /tmp, device: format-7, type: mount, id: mount-7}
    - {name: lv_opt, volgroup: lvm_volgroup-0, size: 5368709120B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-7}
    - {fstype: ext4, volume: lvm_partition-7, preserve: false, type: format, id: format-8}
    - {path: /opt, device: format-8, type: mount, id: mount-8}
    - {name: lv_swap, volgroup: lvm_volgroup-0, size: 2147483648B, wipe: superblock,
      preserve: false, type: lvm_partition, id: lvm_partition-8}
    - {fstype: swap, volume: lvm_partition-8, preserve: false, type: format, id: format-9}
    - {path: '', device: format-9, type: mount, id: mount-9}
    - {path: /boot, device: format-0, type: mount, id: mount-0}
    swap: {swap: 0}
  updates: security
  version: 1

What am I doing wrong that would cause it to stop. Also the autoinstall files has a .cfg extension not a .yaml as I have read in other posts. It would be great to get this working again.

Thanks!

Hi Andrew.
Can you confirm that fqdn like you provide in template is working?

1 Like

This site isn’t designed for technical support. The Finding Help topic details where you can get support for Ubuntu.